Skip directly to content

jukebox srjg

150 posts / 0 new
Dernière contribution
zozodesbois
Portrait de zozodesbois
jukebox srjg

Si vous rencontrez un problème en suivant le Tuto sur le Jukebox SRJG, merci de poster ici.

olivelabidouille
Portrait de olivelabidouille
Jukebox RSS: SRJG questions sur l'install

Bonjour,
Je suis en train de tenter l'installation du Jukebox RSS: SRJG
Tout d'abord merci de cette initiative particulièrement intéressante.
Je précise que je ne suis pas très aguerri dans ce domaine. je dispose d'un HMB 3250 / Firmware GeekyHMB /

- J'ai téléchargé la dernière version de SRJG
- J'ai Dés-archivé les fichiers et les ai mis à la racine d'une clé USB
- J'ai Activé, dans le Setup du HMB le paramètre "IMS Scripts" sur USB

Première question: Le HMB ne voit pas ces deux fichier si j'explore la clé USB, est ce normal? (Je précise que pareillement il ne les voit pas si je pose ces fichiers à la racine d'un HDD USB )

Il est précisé alors de Retourner sur le menu GUIDE puis d'aller sur le menu IMS (Internet Media Services) Et de choisir srjg sans encore lancer le Jukebox.

- Le menu guide c'est la petite maison sur la télécommande j'imagine? Par contre qu'appelez vous menu IMS? Y'a t'il une icone car je ne le trouve pas...

Merci par avance de vos réponses Je procède pas à pas et reviendrais vers vous au fur et à mesure de l'installation.

Olivier

zozodesbois
Portrait de zozodesbois
Jukebox RSS: SRJG questions sur l'install

Bonjour Olivier,
Je viens de modifier le Tuto, dis moi si tu comprends mieux maintenant...
@ Bientôt
Zozodesbois

olivelabidouille
Portrait de olivelabidouille
En effet, ça me parle mieux,

En effet, ça me parle mieux, merci. Mais pour l'instant je suis encore au point mort car le srjg n'est pas dispo dans L'IMS. Je continu à chercher...

HardManBlue
Portrait de HardManBlue
C'est parti !

Bon je commence l'install. Récup OK. Par-contre, pour l'installation, la commande "sh install.sh" ne fonctionne pas car le fichier commence par un "I" et pas un "i". Je continue...

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

zozodesbois
Portrait de zozodesbois
srjg: Majuscule dans le nom du script

Salut HMB,
Merci, j'ai corrigé dans le Tuto.
@ Bientôt
Zozodesbois

HardManBlue
Portrait de HardManBlue
1er essai...

Install OK. Ensuite pour mes premiers essais, les sous-titres fonctionnent. Ca c'est un gros point noir de l'ancienne version qui n'est plus. A tester un peu plus. Bon, par-contre, comme je n'ai pas mes fichiers avec .nfo, je ne peux voir les actions par genre, année. Seul le tri alphabétique fonctionne. Va falloir que je refasse ma collection... Les types de vues fonctionnent mais il faut faire une mise à jour avec "reconstruire", "rapide" ne fonctionne pas. La navigation est lente surtout pour changer de page. Une fois la page chargée, la navigation à l'intérieur est correct.Voilà pour mes premiers essais. En tout cas un très beau travail qui nous permet d'avoir sur nos machines un jukebox performant. Merci Zozodesbois

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

zozodesbois
Portrait de zozodesbois
Jukebox SRJG, première installation

Il faut impérativement faire une mise à jour complète "Reconstruire" pour la première fois.
Même pour ceux qui ont récupéré une ancienne version sur le site de développement: la structure de la base a changé dans certaines versions.

Pareil, si tu récupères des fichiers .nfo après avoir construit le Jukebox, il faut tout reconstruire pour qu'ils soient pris en compte, parce que le film est déja dans la base de donnée.
Astuce: si tu n'as que très peux de .nfo a ajouter, ou a modifier, tu peux simplement renommer les fichiers: ça permet de faire une mise à jour "Rapide" au lieu de tout reconstruire.

olivelabidouille
Portrait de olivelabidouille
Bon ben j'ai progressé mais

Bon ben j'ai progressé mais avec putty j’obtiens un message sh: can't open install.sh

Mais je précise que je ne suis pas familier de putty

zozodesbois
Portrait de zozodesbois
Jukebox Srjg Install.sh

Ce message veut dire que le script Install.sh n'est pas trouvé. En d'autres termes, tu n'es pas situé au bon endroit. Est-ce que tu as bien fait les manips ?
- Tu te positionnes dans le menu IMS, tu voies bien le lien du Jukebox srjg ?
- Tu laisses ton écran comme ça, et tu te connectes en Telnet.
- Tu passes les commandes :
cd /usr/local/etc/scripts/srjg
sh Install.sh
... (Install.sh avec un "I", ça a été corrigé dans le Tuto. La suite sur le Tuto).

leclode
Portrait de leclode
Salut a tous

Salut a tous
L'installation c'est passé sans problème tous a l'air de fonctionner pour le moment.Parcontre peut-on exclure un sous répertoire (comme sur l'ancien jukebox avec la commande exclu.txt)

zozodesbois
Portrait de zozodesbois
Jukebox srjg fonctionnalités à ajouter

Salut Leclode,
Bonne remarque, je vais voir comment ajouter cette fonctionnalité.
@ Bientôt
Zozodesbois

thivame
Portrait de thivame
j'ai plein de question rire

salut zozo,
Votre box est superbe mais voila, ce qui me genait dans la version precedente, c'est que dans un MKV je ne pouvais pas traiter les sous titre (lire les sous titres forcés) et chez moi avec cette nouvelle version je ne peux pas les lire non plus ou mettre des sous titres etranger par exemple, il en ai de meme pour l'audio a premiere vue je ne peux pas changer la piste son (ou alors j'ai pas tout lu correctement)....
Ensuite ma grosse question, comme j'avais deja classé mes videos par genre (j'en avais 11, avec les nfo j'en ai 25, mis a part modifier le genre dans le nfo, y a t il possibilité qu'il prenne le sous dossier comme un genre (un peu comme l'ancienne version)????
Pour commencer je vais modifier tous mes genres dans les nfo et j'essairai de me pencher dessus (quand j'aurais plus de temps).La touche display ne fonctionne pas (elle indique rien, l'ancienne m'indiquait le temps ecoulé et la durée du film)
Donc en resumé chez moi les touches: display, subtitle et audio ne fonctionnent pas avec ce juckebox....
l'ideal ca serait un mix des deux versions rire ...
A plus tard

HardManBlue
Portrait de HardManBlue
Aïe !

Bon alors j'ai fait un peu plus de test. Tout d'abord, après avoir allumé mon HMB et malgré que lors de mes derniers essais étaient concluants, le jukebox ne marchait plus. Impossible de lancer quoi que ce soit depuis le menu principal. J'avais une brève apparition du message "classique" error 404 puis arrêt puis je pouvais reprendre la main mais sans rien pouvoir faire de nouveau. J'ai relancé le script d'install et le jukebox re-fonctionne.
Ensuite, je suis d'accord : les touches display et audio ne fonctionnent plus. quant aux sous-titres, le temps d'affichage du panel de config est extrêmement long. Ensuite, je ne suis jamais arrivé à afficher le moindre sous-titre d'une vidéo déjà regardé ou je sais qu'il y en a bien. Comment faire ? Manque-t-il les polices ?

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

jesus
Portrait de jesus
Probleme au lancement

Bonjour,

Je viens de tester se superbe jukebox et j'ai un gros problème j'ai tester sur disque dur et usb et j'ai reflasher HMB cela ne résout rien.

J'arrive sur le menu Sélection par, et lorsque je vais sur un des bouton (config ou autres) j'ai l'icone conneted qui apparet un cour instant et rien ne se passe.

Merci

HMB-R3250 - 1 disque système 120 Go et disque data divers capacité - Firmware C757

HardManBlue
Portrait de HardManBlue
Essaie comme moi (article du dessus)

relance l'install

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

zozodesbois
Portrait de zozodesbois
Jukebox

Vous savez quoi ? Je suis en vacances !!! smiley (donc pas chez moi, et pas de HMB sous la main)
Alors il va falloir patienter un peu et chercher un peu...

Pour les Sous-titres, ce que j'explique depuis presque un an déjà wink c'est que nous n'avons pas les sources du DvdPlayer.
Donc avec des astuces, nous avons réussi à afficher du texte sur la vidéo (Merci à vb6rocod pour son code) C'est encore expérimental...
C'est ce sous-titrage là qui est pris en chage, c'est le principe basé sur les fichiers .srt (voir tuto juste pour les .srt)
Nous utilisons une autre méthode pour lire les fichiers ISO, qui est comme sur l'ancien Jukebox, ça devrait lire les sous-titres qui sont dans l'ISO. Je n'ai pas testé (a voir pour les MKV, mais s'ils ne marchaient pas sur l'ancien Jukebox, il ne faut pas chercher, la seul solution que j'ai pour le moment c'est d'ajouter des fichiers .srt).

Cette nouvelle méthode de lecture des vidéos permet aussi d'utiliser un popup pour l'avance rapide (touche Goto)

La touche "Subtitle" ne marche pas, parce qu'on ne peut pas la capturer, le seul moyen qu'il y a de faire ça, c'est de modifier le firmware. Alors on a pris la touche "Edit", qui va vous permettre de changer de police et de couleurs s'il y a un fichier .srt bien sûre...

Voilà pour le moment... ne cassez pas tout, je reviens bientôt.
@ Bientôt
Zozodesbois

HardManBlue
Portrait de HardManBlue
Comment ?

Comment ? pendant que nous testons le nouveau jukebox, monsieur prend des vacances (lol) Bon ben j'avais pas vu que les sous-titres c'était pour les fichiers .srt mais la perte des touches display et audio ? Ça va me permettre de créer mes .nfo après premier essai avec, les genres,dates fonctionnent et çà rend plutôt bien. Allez bonne vacances....car on t'attend au retour !

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

thivame
Portrait de thivame
genre

bonjour
j'ai modifié sur les nfo les genres pour que cela corresponde a ce que j'avait auparavant. Dans le dossier image des genres j'ai mis celles qui correspondaient au nouveaux genre rentrés, mais voila maintenant j'ai ecran noir je pensais qu'en mettant une image ayant le meme nom de genre que dans le nfo , cela allait les "relier" mais non maintenant il ne m'affiche que "inconnu" et "tous les films"...
Quelqu'un aurait il la solution ?? (je n'ai pas envi de me retaper tous mes films a faire en nfo...sniff

HardManBlue
Portrait de HardManBlue
Genre...koi ?

Les genres sont expliqués dans le tuto. Extrait :
"Les genres

Comme je l'ai dit plus haut, les genres sont définis dans les fichiers .nfo Ce sont des simple fichiers texte, s'il y a quelque chose que vous voulez changer, modifiez le avec votre éditeur favori sur un ordinateur.

Vous pouvez gérer les genres en les regroupant grâce a deux fichiers (qui se trouvent dans le dossier "lang"):
fr_genre

Ce fichier va permettre de faire pointer un genre vers une image existante

|Comédie musicale>Music|

Ici l'image Music.jpg sera utilisée pour le genre "Comédie musicale". Vous pouvez soit ajouter une image avec le nom d'un genre qu'il vous manque, soit faire pointer le nom du genre vers une image. Vous pouvez utiliser plusieurs fois la même image."

Ceci veut dire que dans le fichier .nfo si tu as "drame", il faut qu'il y ait une image correspondant dans le fichier fr_genre. Si tu crés des genres qui ne sont pas définis dans ce fichier, il faut les rajouter avec soit la même image, soit une autre image. Tu peux ainsi gêrer autant de genre que tu veux. Je suis en train de refaire ma collection et du coups, je pense créer de nouvelles images si besoin. Après je les mettrais en partage. On peut même imaginer des "packs" si tout le monde s'y met...

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

zozodesbois
Portrait de zozodesbois
Srjg Jukebox

Salut,
@ Thivame,
Si tu touches aux fichiers .nfo, il faut reconstruire complètement le Jukebox.
Pour être sûr de ce que tu fais, tu peux en modifier juste 1 en renommant le film qui correspond et tu fais une reconstruction "rapide". Comme ça tu voies si ce que tu as fait c'est bon ou pas avant de faire une reconstruction totale.
Les .nfo ont une structure spéciale avec des balises qu'il faut respecter...
Tu peux aussi utiliser IMDB qui va te télécharger tous les .nfo qu'il te manque (en utilisant fr_allocine, si tu les veux en Français).

@ HMB,
Oui ça perturbe un peu le fait que le peu de touches qui marchaient ne fonctionnent plus, mais la commande playItemURL(); de base, joue les vidéos comme dans l'ancien Jukebox (la touche sous-titre ne marche pas). Les options que l'on a découvertes permettent d'afficher des choses sur la vidéo, mais ça désactive le peut de touches qui marchaient.
Pour "info/display", je vous ai dit qu'il y a la touche "Goto" qui permet de savoir où en est la vidéo avec un compteur, et de se positionner là où on veut (Seekpopup).
Le volume, je ne m'en sert pas, je me sert de celui de ma chaîne... On va voir ce que l'on peut faire pour rajouter ça, puisque j'ai vu (si je n'ai pas rêvé) qu'il y a une commande pour le volume.

@ Tous,
L'ajout des sous-titres étant très récent, je n'ai pas eu le temps de documenter, mais pendant la vidéo, lorsque les sous-titres s'affichent, on peut faire monter/descendre les sous-titre avec les flèches haut et bas.
Le menu des sous-titre pendant la vidéo, c'est la touche "edit", il y a quelques réglages (couleur de la police, couleur du fond etc...)
Il y a d'autres options pour les sous-titre dans le menu de config, affichage.
Par défaut, c'est la police du système qui est utilisé.
Vous pouvez en ajouter d'autres dans le dossier "font" de srjg, ou décider d'un autre endroit si vous voulez.
Il y a d'autres polices dans le Firmware, pour y accéder, il faut choisir les chemins:
/usr/local/bin/Resource (4 polices).
/usr/local/bin/Resource/CC_Font (7 polices).

Je vais devoir passer quelques jours sans ordinateur (snif...) alors merci à HMB pour ton soutien.
Essayez de relire le Tuto, ça évitera de tout recopier dans le forum...

@ Bientôt
Zozodesbois

HardManBlue
Portrait de HardManBlue
M'enfin !

M'enfin ! comment c'est pas le tuto ici ? ah ben on me dit jamais rien aussi ! Bon ben je retourne faire mes tests alors...

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

jesus
Portrait de jesus
Configuration impossible

Bonjour,

Je me retrouve bloquer sur écran Sélection par : (Genre, année...) j'ai erreur 404 sur chaque bouton.

J'ai Flasher 3x d'affiler avec le Frimware C757 Elion et GeekyHMB pour HMB 3250, puis installer le Jukebox RSS: SRJG sur USB.

J'ai effectuer en telnet :

cd /usr/local/etc/scripts/srjg
sh Install.sh

sh srjg_update.sh -u

Une fois l'update effectuer il me trouve bien 1 film sur la clés USB, le menu bloque toujours.

Es que j'ai zapper un truc, je comprend plus rien.

Merci

HMB-R3250 - 1 disque système 120 Go et disque data divers capacité - Firmware C757

HardManBlue
Portrait de HardManBlue
Sosu-titres SRT...Aïe !

Bon alors j'ai récupéré un fichier .srt pour une de mes vidéos ou il y a aussi des sous-titres (ah le mkv). Impossible de lire la vidéo depuis le jukebox. Il reboote à chaque fois. Si j'essaie depuis l'explorateur classique du HMB et que pendant la lecture de la vidéo, j'active les sous-titres, je vois bien les sous-titres de la vidéo puis le .srt et ça marche. C'est donc le jukebox qui n'arrive pas à le gérer...
Pour ce qui est de la touche Goto, problème aussi et ce suivant le type de fichier à priori. Avec un mkv, la fenêtre apparait et disparait aussitôt sans pouvoir rien faire. Avec un .iso, la fenêtre reste mais plantage si recherche avec titre. Avec un .avi, ça ne marche pas non plus...

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

thivame
Portrait de thivame
je m'explique

Men fait dans mon hdd j'aime bien faire la difference entre un film avi lambda et un hd, donc j'ai essayé de modifié le nfo en mettant de genre "hd"
<genre>
<name> hd</name>
</genre>
et dans le dossier genre j'ai evidement mis une image "hd"
mais cela ne marche pas j'ai ecran noir

HardManBlue
Portrait de HardManBlue
Config

Salut Thivame,
As-tu mis à jour le fichier fr_genre (sous lang je crois) ?
Ce fichier va te permettre de faire pointer un genre vers une image existante.Dans ton cas, il faut que tu rajoutes " HD>hd "
L'image hd.jpg sera utilisée pour le genre "HD".

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

thivame
Portrait de thivame
voila

voila le hic
c'est cela que je cherchais ...je ne savais pas comment faire pointer sur l'image... du moins je ne l'avais pas compris...je vais essayer
thanks par avance

edit: bon et bien toujours pareil ecran vierge...je vais tout refaire....

HardManBlue
Portrait de HardManBlue
Autre mauvais point, l'affichage...

Autre mauvais point, l'affichage... En effet, lorsque l'on est en mode vue sheetwall,les images situées en bas de l'écran sont coupées de 1/3, que ce soit avec les genres, dates, tri alpha. C'est vraiment pas beau. C'est le même souci qu'avec les fonds d'écran à mon avis qui avec une taille correcte de 1920x1080p voient pourtant le contour coupé. Il faut donc prévoir une correction de l'affichage. En parlant d'affichage, il n'y a pas eu une version avec le choix dans la config d'afficher l'aide ou pas ?

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

jesus
Portrait de jesus
Bug ?

Bonjour,
- Coter firmware lorsque l'on lancer la commande sh Install.sh sur firmware Elion il y a un backup qui se créer pas sur firmware GeekyHMB es-ce normal ?

Pour le problème des bouton maintenant cela fonctionne presque :

Après avoir lancer Install.sh je lance le script, je fais réglage, chemin film, mise a jour, la il me trouve bien le film. Youpi

Et bien non lorsque je coupe l'interrupteur arrière HMB et relance l'appareil les bouton me refont erreur 404 et il faut relancé le script d'install et le jukebox re-fonctionne. Et je dois le refaire a chaque fois que l'appareil a été éteint.

HMB-R3250 - 1 disque système 120 Go et disque data divers capacité - Firmware C757

jesus
Portrait de jesus
Dossier SRJG

Chausse bisard que j'ai remarquer lors de la mise a jour sur Clés USB j'ai un dossier SRJG qui se crée bien mais pas a partir des disque dur ?

Même avec se dossier sur clés USB cela ne résous pas le problème qu'il faut refaire une mise a jour après avoir redémarrer l’appareil.

HMB-R3250 - 1 disque système 120 Go et disque data divers capacité - Firmware C757

HardManBlue
Portrait de HardManBlue
Pb USB

Cela me fait la même chose. Tant que le HMb reste sous tension, pas de pb. Si je le coupe électriquement et le rallume, le jukebox ne fonctionne plus. Il faut relancer l'install sous telnet. En fait, le jukebox perd le chemin du répertoire des vidéos qui sont sous USB. Il va falloir que Zozodesbois trouve un moyen d'enregistrer le chemin dans un fichier...
Sinon autre test, la gestion des vidéos par la touche EDIT a l'air de fonctionner correctement.

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

zozodesbois
Portrait de zozodesbois
srjg 404 suite à coupure électrique

Salut !
Et oui, c'est fini les vacances... frown
Je vois qu'il y a pas mal de choses a faire ici.
Je reviendrai sur les autres points, mais je pense que l'erreur 404 suite à l'extinction électrique du HMB, vient que je me suis fait avoir dans le script d'install parce que l'on utilise des liens symboliques, et que ma config avait des choses en dur.

Je vais faire des tests dès que possible, mais je pense que la solution c'est d'ajouter un petit "d" dans la commande du script qui est dans le dossier cgi (GeekyHMB_cgi.sh)

cp -rpd /usr/local/etc/GeekyHMB/cgi-bin/* /tmp/www/cgi-bin/

Puis de relancer l'install.
@ Bientôt
Zozodesbois

Vincent
Portrait de Vincent
Lenteur dans la navigation entre écran

Bonjour,
j'ai installé ce super jukebox, par contre chez moi la navigation est extrêmement lente. C'est à dire que le temps de chargement entre un écran et un autre prend pas mal de temps (30 / 40 secondes) voir plus. Ai-je loupé quelque chose ?
merci

HardManBlue
Portrait de HardManBlue
OK !

Salut mon Zozodesbois, content de te revoir !
Bon j'ai essayé la modif. comme tu l'as décrite.N'a pas fonctionné le premier coup. Du coup, j'ai modifié aussi le fichier GeekyHMB_cgi.sh sous /usr/local/etc/GeekyHMB en rajoutant le "d" dans la commande du shell. A priori, ça fonctionne. Eteint-rallumé, le jukebox fonctionne et le chemin de mon DD USB n'est plus perdu.
Je précise que j'avais bien relancé l'install

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

zozodesbois
Portrait de zozodesbois
Jukebox erreur 404

@ HardManBlue,
Merci. Oui, tu as raison, j'ai vérifié le script d'install, il faut aussi que je le modifie pour qu'il force la copie du GeekyHMB_cgi.sh. C'est dingue tout ces tracas pour un simple petit "d"...

@ Vincent,
En effet, les temps que tu as ne sont pas normaux... au plus ça prend 4s entre les menus.
Éteins électriquement ton HMB, ça va nettoyer tout ce qu'il y a dans /tmp
Et refait l'install si tu n'as pas fait la petite bidouille expliquée juste au dessus.

zozodesbois
Portrait de zozodesbois
srjg révision 221

Je viens de mettre à disposition la dernière révision r221:
- Gère les fichiers exclu.txt: si un fichier exclu.txt est détecté pendant une mise à jour, tous les films situés dans le même dossier que le fichier exclu.txt seront ignorés.
- L'install corrige le problème 404 après extinction électrique du HMB.
@ Bientôt
Zozodesbois

HardManBlue
Portrait de HardManBlue
Allez...

Install de la r221 faite. A priori OK. Pas testé le fichier d'exclu.

HMB Movie Palace, 1 To en Interne, 2 x 2To en externe, Firmware V2.1 C757, of Course !

diskatorat
Portrait de diskatorat
fr_genreGrp

Bonjour à tous,

C'est un super travail ce jukebox zozo, merci à toi !

si je modifie le fichier fr_genreGrp (sur le clé USB, car je ne le trouve pas ailleurs), dois-je relancer l'installation pour que la modification soit prise en compte ?
Si non, cela vaut dire que la clé USB doit rester dans le movie palace pour que le jukebox fonctionne ? N'y-a-t-il pas moyen de le mettre sur le disque dur interne ?

sorry, si ma question semble évidente pour certains... !-)

Diska

zozodesbois
Portrait de zozodesbois
srjg jukebox sur hdd

Salut Diska,
Merci :)

Bien entendu que tu peux mettre le Jukebox sur ton HDD. Tu mes tes deux dossiers sur ton disque, comme tu l'as fait avec ta clé, puis dans la configuration du Guide, pour l'IMS, tu choisis HDD au lieu de USB.

Oui, si tu fais une modification dans fr_genreGrp, il faut faire une mise à jour complète si ça concerne beaucoup de films... sinon, tu te contentes de retirer (ou renommer) juste les films concernés et tu fais une mise à jour "rapide".

Petit complément d'info, pour un nouveau genre (qui est déjà dans les fichiers .nfo), tu peux te contenter d'ajouter une image avec le nom de ton genre sans toucher aux deux fichiers de gestion des genres, elle devrait être prise en compte sans rien reconstruire.

@ Bientôt
Zozodesbois

Vincent
Portrait de Vincent
les lenteurs envolées....

@zozodesbois : après mise à jour en dernière version et redémarrage électrique de mon HMB, tout fonctionne correctement, envolés mes problèmes de lenteur. Merci

diskatorat
Portrait de diskatorat
srjg sur hdd

Ok Zozo, merci... ça fonctionne bien !
La seule chose, c'est que quand je met la config IMS sur HDD sans les deux dossiers du SRJG, j'ai toute une série de possibilités (Picasa, radio, etc...) mais que je met les deux dossiers, je n'ai plus que le SRJG... je ne sais pas si c'est normal...

Diska

zozodesbois
Portrait de zozodesbois
Config IMS sur HDD

@ Vincent, c'est cool.

@ Diska, c'est normal, lorsque les dossiers IMS ne sont pas trouvés, c'est le dossier IMS système qui est pris en compte.
Si tu veux ajouter quelque chose au menu IMS normal, soit tu copies ton Jukebox dans les dossiers du Firmware, mais il y a des contraintes de protection contre l'écriture et tu vas vite avoir un problème de place... soit tu recopies tes fichiers IMS de ton Firmware sur ton disque dur, dans lesquels tu ajoutes le Jukebox:
La copie tu peux la faire en Telnet

cp /usr/local/bin/IMS_scripts /chemin de ton disque, ou de ta clé/
cp /usr/local/bin/IMS_image /chemin de ton disque, ou de ta clé/

Ou bien récupérer les fichiers dans ton Firmware (voir tuto pour désarchiver le Firmware)
Ou bien tu les récupères dans les téléchargements du GeekyHMB la dernière version du IMS_Cxxx.zip.

Pour ajouter le Jukebox au pack d'origine :

  • copie le dossier srjg dans le dossier IMS_Script.
  • modifie le fichier menu.rss, dans lequel tu ajoutes les lignes suivantes vers la fin après --> et juste avant les balises </channel></rss>:
<item>
    <title>Jukebox SRJG</title>
    <link>rss_file://./scripts/srjg/SrjgMainMenu.rss</link>
    <media:thumbnail url="scripts/srjg/images/srjglogo.jpg" width="120" height="90" />
</item>

Attention, il faut bien respecter la notion de balises, sinon ça ne marche pas.
@ Bientôt
Zozodesbois

thivame
Portrait de thivame
est il possible

Bonsoir,
je viens de regarder le script, ouahhh il est plus compliqué que les precedent...
J'ai toutefois essayé de faire un truc mais marche pas....je voudrais tout simplement faire deux juckebox srjg ... je m'explique faire un menu avec un nom de dossier....(film par exemple) et un deuxieme nom (clip par exemple) j'ai essayé mais j'ai une erreur pour le deuxieme dossier... malheureusement je n'ai pas le temps en ce moment de tout decortiquer comme j'ai eu le temps de le faire dans la V2..donc avant d'essayer de trouver ce temps.. j'aimerais savoir si cela est possible???
merci
Cordialement

zozodesbois
Portrait de zozodesbois
Plusieurs Jukebox

Salut Thivame,
Oui, c'est prévu. C'est quoi "marche pas", tu as plus de détail ?
Tu peux avoir autant de Jukebox que tu veux et en changer tout simplement en mettant le chemin de ton Jukebox.
Il faut cependant que la config soit cohérente, il faut que tu aies autant de bases de données que de Jukebox:
SingleDb doit être à "no" (ou sur ta TV: Base unique à "non")
Pour éviter les doublons, tu peux aussi préciser
Nfo_Path, Poster_Path et Sheet_Path dans le chemin du Jukebox MoviesPath ou SRJG (ou sur ta TV: Chemin Nfo, Chemin Jaquettes, Chemin Sheet avec MoviesPath ou SRJG).
Cela ne marche pas avec un NAS en lecture seule, dans ce cas particulier, tu es obligé de mettre qu'une seule base de donnée qui sera stockée a un seul endroit.
@ Bientôt
Zozodesbois

diskatorat
Portrait de diskatorat
srjg

Salut à tous,

lors de la mise à jour via telnet (reconstruction), j'ai ce message plein de fois:
sed: unsupported command '

est-ce normal ?

et ensuite, via Genre, je n'ai plus que deux genres "tous les films" et "unknow"

il faut dire que j'ai déplacé les dossiers IMS vers le root du disque dur après l'installation...

Que faire pour récupérer les genres ?

Merci
Diska

diskatorat
Portrait de diskatorat
srjg

je viens de refaire l'install et la reconstruction mais c'est toujours pareil, je n'ai plus les genre...
par contre en alphabétique, j'ai bien tous les films...
les deux fichiers fr_genre et fr_genreGrp sont bien là aussi...
les fichiers nfo sont également là...

Que faire ?
Diska

zozodesbois
Portrait de zozodesbois
Pb suite a déplacement des dossiers IMS

Salut Diska,
sed: unsupported command, ça veut dire que la commande sed, utilisée par le Jukebox ne fonctionne pas...
J'ai un peu de mal à comprendre ce que tu as fait, parce que ça ne devrait pas poser de problème si tu copies tes dossiers IMS depuis ta clé, et que tu les mets à la racine de ton disque dur.
A moins que tu ne soies reparti du dossier original ? Mais, ça n'explique pas l'erreur que tu as avec sed...
Pourquoi parles-tu des fichiers .nfo ? Ils n'ont rien à faire dans ton dossier IMS_script.
Est-ce que tu aurais mis tes films dans le dossier IMS ?

diskatorat
Portrait de diskatorat
srjg

merci de me répondre zozo,
voila, donc tout d'abord, j'ai mis les dossiers IMS sur une clé usb et j'ai suivi le tuto... tout fonctionnait bien... (j'ai fait un construction avec lmb on)
ensuite, j'ai copié les dossier IMS de la clé USB vers le root du disque dur interne. J'ai modifié la config IMS de USB en HDD...
j'avais modifié quelque chose dans fr_genreGrp et j'ai relancé une reconstruction en ayant désactiver lmb pour gagner du temps (via le jukebox) il y a eu un message "404 not found" après que le process ai travaillé pendant environ 5 min.
Après cela, je n'avais plus les genres !
j'ai donc remis ce qui était à l'origine dans le fichier fr_genreGrp
j'ai relancer une construction via telnet pour voir les messages et là j'ai vu les erreur sed...
ok, j'ai alors refait la commande d'installation via telnet, me disant que comme j'avais déplacé les dossiers IMS il fallait peut être réinstaller...
je suis retourné dans le jukebox mettre le chemin des films et j'ai relancé le update via telnet...
mais toujours pareil...

donc, dans mon disque interne, j'ai
Films ==> là ou sont les films
IMS_Scripts
IMS_Image

Merci,
Diska

zozodesbois
Portrait de zozodesbois
srjg pb install sur HDD

Je ne pense pas que ça vienne du script d'install: il copie le fichier de config dans /usr/local/etc/srjg.cfg et il active les liens pour qu'après un arrêt électrique, ils soient toujours dans /tmp/www/cgi-bin.

Je pense plutôt que ton problème vient des fichiers genre, vu qu'il met 5 minutes pour afficher un pb avec sed...
Pour en être sûr, refais l'install du Tuto sur ton HDD, en partant du paquet srjg d'origine (celui que tu as téléchargé) sans modifier quoi que ce soit dans les genres ou autre.
Lances l'install.sh et fais tes réglages de config sur ta TV.
Fais une mise à jour complète (en telnet ou sur la TV).
Si ça marche, c'est qu'il y a quelque chose que tu fais avec les genres qui ne va pas... Ca m'intéresse de savoir ce que c'est...
@ Bientôt
Zozodesbois

diskatorat
Portrait de diskatorat
srjg pb install sur HDD

Ok, y-a-t-il un moyen de désinstaller le tout avant de réinstaller ?

Merci
Diska

zozodesbois
Portrait de zozodesbois
srjg pb install sur HDD

Il suffit de supprimer les dossiers IMS de ton HDD, de les remplacer par ceux de l'archive du Tuto, puis de faire ce que je te demande dans le précédent commentaire...

Pages

Se connecter or register to post comments